const regex = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*([^a-zA-Z\d\s])).{9,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[a-z])(?=.*[A-Z])(?=.*\\d)(?=.*([^a-zA-Z\\d\\s])).{9,}$', 'gm')
const str = `Pass2withUnderScore_Case
Pass2withUnderScore_Case!
Pass2withUnderScoreCase!
Pass2withUnderScoreCase
asdfasfdsxxxxxxxxxxxxxxxxxxxxxxxxxxx
FASDFASDFASDXXXXXXXXXXXXXXXXXXXX
143241234xxxxxxxxxxxxx
a1234xxxxxxxxxxxxxxxxxx
A1234XXXXXXXXXXXXXXXXXXXXXXX
Pass2withUnderScoreCase
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}