import re
regex = re.compile(r"^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*([^a-zA-Z\d\s])).{9,}$", flags=re.MULTILINE)
test_str = ("Pass2withUnderScore_Case\n"
"Pass2withUnderScore_Case!\n"
"Pass2withUnderScoreCase!\n"
"Pass2withUnderScoreCase\n\n"
"asdfasfdsxxxxxxxxxxxxxxxxxxxxxxxxxxx\n"
"FASDFASDFASDXXXXXXXXXXXXXXXXXXXX\n"
"143241234xxxxxxxxxxxxx\n"
"a1234xxxxxxxxxxxxxxxxxx\n"
"A1234XXXXXXXXXXXXXXXXXXXXXXX\n"
"Pass2withUnderScoreCase\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")