re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*([^a-zA-Z\d\s])).{9,}$/m
str = 'Pass2withUnderScore_Case
Pass2withUnderScore_Case!
Pass2withUnderScoreCase!
Pass2withUnderScoreCase
asdfasfdsxxxxxxxxxxxxxxxxxxxxxxxxxxx
FASDFASDFASDXXXXXXXXXXXXXXXXXXXX
143241234xxxxxxxxxxxxx
a1234xxxxxxxxxxxxxxxxxx
A1234XXXXXXXXXXXXXXXXXXXXXXX
Pass2withUnderScoreCase
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end