using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(xi-)?(([A-Za-z0-9]+)_?)-.*";
string substitution = @"$2 or $3";
string input = @"xi-AN224432_-_this_is_some_text-x10.pdf
xi-F1800X7T2P5P-blahblah-v01_00-EN.pdf
1E303S-blahblah-v01_20-EN.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}