$re = '/^0[13](?!0*[1-9]0)[0-9]{6}[0-9]$/m';
$str = '010010628
010001628
010001234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);