Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])
"
gm
Test String
New
TRACE(&logger_mr , DEBUG_2 , NULL , UdpPathMgmtLogger::entranceStr_sc;
Substitution
Processing...
\1 "%s" \6