const regex = new RegExp('(TRACE(\\s*)\\(\\S+\\s*[,](\\s*\\S+\\s*)[,\\n](\\s*\\S+\\s*)[,](\\s*))([^\\"])', 'gm')
const str = `TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
`;
const subst = `\1 "%s" \6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);