// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])"#).unwrap();
let string = "TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
";
let substitution = "\\1 \"%s\" \\6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}