// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"https(.*?)200x200(.*)""#).unwrap();
let string = "Some text
{\\\"url\\\": \\\"https:\\/\\/www.someurl.com\\/200x200\\/fsdffsde3e\", \\\"bbb\\\"} kljkl
{\\\"url\\\": \\\"https:\\/\\/www.someurl.com\\/500x500\\/fsdffsde3e\", \\\"bbb\\\"} kljkl
Some text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}