#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?!\*|\\\*)*?)(\*\\\*)|(\\\*\*)|(\*)|(\\\*)"
Local $sString = "*" & @CRLF & _
"\*" & @CRLF & _
"test" & @CRLF & _
"*test*" & @CRLF & _
"\*test\*" & @CRLF & _
"\\*" & @CRLF & _
"\**"
Local $sSubst = "$1${2:+\\\*\*}${3:+\*\\\*}${4:+\\\*}${5:+\*}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)