use strict;
my $str = '*
\\*
test
*test*
\\*test\\*
\\\\*
\\**';
my $regex = qr/((?!\*|\\\*)*?)(\*\\\*)|(\\\*\*)|(\*)|(\\\*)/mp;
my $subst = '$1${2:+\\\\\\*\\*}${3:+\\*\\\\\\*}${4:+\\\\\\*}${5:+\\*}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";