const regex = /([\s\S].*?)(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S].*?)(\\d+)', 'gm')
const str = `Some random text --- e-1-e-20-e-3`;
const subst = `$2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);