using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^\[\]]*\]\s*(<>|<=|>=|=|>|<)\s*'?""?\w*'?""?";
string input = @"[household_roster_relationships_topersona_nameadditionalpersono] = ""1"" OR [household_roster_relationships_topersona_nameadditionalpersono] >= ""1"" ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}