package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)first[\d\D]*second`)
var str = `
first line
second line
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}