$re = '/a_file_\w+\.xml/m';
$str = '4345t435
g54t a_file_123.xml rk
greg a_file_j34.xml fger 43t54';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);