#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([Aa]{2,})r{1}o{1}n{1}$"
Local $sString = "AAron" & @CRLF & _
"aaron" & @CRLF & _
"aaaaaaaaaron " & @CRLF & _
"aaaaaaaaaronnnn " & @CRLF & _
"aaaaaaaaaroooon " & @CRLF & _
"aaaaaaaaarrrron " & @CRLF & _
"aron"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")