$re = '/(\d+)[^\d]+some[wW]ord/';
$str = '43434 of someword 12 anything 45 someword 2323 new someword
43434 of someWord 12 anything someWord 2323 new someWord';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);