re = /(\d+)[^\d]+some[wW]ord/
str = '43434 of someword 12 anything 45 someword 2323 new someword
43434 of someWord 12 anything someWord 2323 new someWord'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end