Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\d+)[^\d]+some[wW]ord
/
g
Input 1
1
New
43434 of someword 12 anything 45 someword 2323 new someword 43434 of someWord 12 anything someWord 2323 new someWord