#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+)[^\d]*[^\w]some[wW]ord[^\w]"
Local $sString = "43434 of someword 12 anything 45 someword 2323 new someword" & @CRLF & _
"43434 of someWord 12 anything someWord 2323 new someWord" & @CRLF & _
"43434 of notsomeWord 12 anything someWordNotThis 2323 new notsomeWord" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")