const regex = /(\d+)[^\d]*[^\w]some[wW]ord[^\w]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)[^\\d]*[^\\w]some[wW]ord[^\\w]', 'g')
const str = `43434 of someword 12 anything 45 someword 2323 new someword
43434 of someWord 12 anything someWord 2323 new someWord
43434 of notsomeWord 12 anything someWordNotThis 2323 new notsomeWord
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}