$re = '/(\d+)[^\d]*[^\w]some[wW]ord[^\w]/';
$str = '43434 of someword 12 anything 45 someword 2323 new someword
43434 of someWord 12 anything someWord 2323 new someWord
43434 of notsomeWord 12 anything someWordNotThis 2323 new notsomeWord
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);