#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+_(.+\-\d+\-\d+\-.+)"
Local $sString = "LB_AB_BookingReminder_123-1-2-1S" & @CRLF & _
"LB_AB_123-1-2-1S" & @CRLF & _
"LB_AB_Booking_Reminder_123-1-2-1S"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")