#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=version:\s\s\s\s\s\s\s\s)\d+(\.\d+)+"
Local $sString = "filename: /usr/lib/modules/5.7.7-967.native/kernel/drivers/video/nvidia.ko" & @CRLF & _
"alias: char-major-195-*" & @CRLF & _
"version: 450.57" & @CRLF & _
"supported: external" & @CRLF & _
"license: NVIDIA" & @CRLF & _
"srcversion: CCB2AEF641D4CD7A82E48B3" & @CRLF & _
"alias: pci:v000010DEd*sv*sd*bc03sc02i00*" & @CRLF & _
"alias: pci:v000010DEd*sv*sd*bc03sc00i00*" & @CRLF & _
"depends:" & @CRLF & _
"retpoline: Y" & @CRLF & _
"name: nvidia" & @CRLF & _
"vermagic: 5.7.7-967.native SMP mod_unload" & @CRLF & _
"parm: NvSwitchRegDwords:NvSwitch regkey (charp)" & @CRLF & _
"parm: NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)" & @CRLF & _
"parm: nv_cap_enable_devfs:nv_cap_enable_devfs=0 or 1 (int)" & @CRLF & _
"parm: NVreg_ResmanDebugLevel:int" & @CRLF & _
"parm: NVreg_RmLogonRC:int" & @CRLF & _
"parm: NVreg_ModifyDeviceFiles:int" & @CRLF & _
"parm: NVreg_DeviceFileUID:int" & @CRLF & _
"parm: NVreg_DeviceFileGID:int" & @CRLF & _
"parm: NVreg_DeviceFileMode:int" & @CRLF & _
"parm: NVreg_InitializeSystemMemoryAllocations:int" & @CRLF & _
"parm: NVreg_UsePageAttributeTable:int" & @CRLF & _
"parm: NVreg_MapRegistersEarly:int" & @CRLF & _
"parm: NVreg_RegisterForACPIEvents:int" & @CRLF & _
"parm: NVreg_EnablePCIeGen3:int" & @CRLF & _
"parm: NVreg_EnableMSI:int" & @CRLF & _
"parm: NVreg_TCEBypassMode:int" & @CRLF & _
"parm: NVreg_EnableStreamMemOPs:int" & @CRLF & _
"parm: NVreg_EnableBacklightHandler:int" & @CRLF & _
"parm: NVreg_RestrictProfilingToAdminUsers:int" & @CRLF & _
"parm: NVreg_PreserveVideoMemoryAllocations:int" & @CRLF & _
"parm: NVreg_DynamicPowerManagement:int" & @CRLF & _
"parm: NVreg_DynamicPowerManagementVideoMemoryThreshold:int" & @CRLF & _
"parm: NVreg_EnableUserNUMAManagement:int" & @CRLF & _
"parm: NVreg_MemoryPoolSize:int" & @CRLF & _
"parm: NVreg_KMallocHeapMaxSize:int" & @CRLF & _
"parm: NVreg_VMallocHeapMaxSize:int" & @CRLF & _
"parm: NVreg_IgnoreMMIOCheck:int" & @CRLF & _
"parm: NVreg_NvLinkDisable:int" & @CRLF & _
"parm: NVreg_EnablePCIERelaxedOrderingMode:int" & @CRLF & _
"parm: NVreg_RegisterPCIDriver:int" & @CRLF & _
"parm: NVreg_RegistryDwords:charp" & @CRLF & _
"parm: NVreg_RegistryDwordsPerDevice:charp" & @CRLF & _
"parm: NVreg_RmMsg:charp" & @CRLF & _
"parm: NVreg_GpuBlacklist:charp" & @CRLF & _
"parm: NVreg_TemporaryFilePath:charp" & @CRLF & _
"parm: NVreg_AssignGpus:charp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")