# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=version:\s\s\s\s\s\s\s\s)\d+(\.\d+)+"
test_str = ("filename: /usr/lib/modules/5.7.7-967.native/kernel/drivers/video/nvidia.ko\n"
"alias: char-major-195-*\n"
"version: 450.57\n"
"supported: external\n"
"license: NVIDIA\n"
"srcversion: CCB2AEF641D4CD7A82E48B3\n"
"alias: pci:v000010DEd*sv*sd*bc03sc02i00*\n"
"alias: pci:v000010DEd*sv*sd*bc03sc00i00*\n"
"depends:\n"
"retpoline: Y\n"
"name: nvidia\n"
"vermagic: 5.7.7-967.native SMP mod_unload\n"
"parm: NvSwitchRegDwords:NvSwitch regkey (charp)\n"
"parm: NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)\n"
"parm: nv_cap_enable_devfs:nv_cap_enable_devfs=0 or 1 (int)\n"
"parm: NVreg_ResmanDebugLevel:int\n"
"parm: NVreg_RmLogonRC:int\n"
"parm: NVreg_ModifyDeviceFiles:int\n"
"parm: NVreg_DeviceFileUID:int\n"
"parm: NVreg_DeviceFileGID:int\n"
"parm: NVreg_DeviceFileMode:int\n"
"parm: NVreg_InitializeSystemMemoryAllocations:int\n"
"parm: NVreg_UsePageAttributeTable:int\n"
"parm: NVreg_MapRegistersEarly:int\n"
"parm: NVreg_RegisterForACPIEvents:int\n"
"parm: NVreg_EnablePCIeGen3:int\n"
"parm: NVreg_EnableMSI:int\n"
"parm: NVreg_TCEBypassMode:int\n"
"parm: NVreg_EnableStreamMemOPs:int\n"
"parm: NVreg_EnableBacklightHandler:int\n"
"parm: NVreg_RestrictProfilingToAdminUsers:int\n"
"parm: NVreg_PreserveVideoMemoryAllocations:int\n"
"parm: NVreg_DynamicPowerManagement:int\n"
"parm: NVreg_DynamicPowerManagementVideoMemoryThreshold:int\n"
"parm: NVreg_EnableUserNUMAManagement:int\n"
"parm: NVreg_MemoryPoolSize:int\n"
"parm: NVreg_KMallocHeapMaxSize:int\n"
"parm: NVreg_VMallocHeapMaxSize:int\n"
"parm: NVreg_IgnoreMMIOCheck:int\n"
"parm: NVreg_NvLinkDisable:int\n"
"parm: NVreg_EnablePCIERelaxedOrderingMode:int\n"
"parm: NVreg_RegisterPCIDriver:int\n"
"parm: NVreg_RegistryDwords:charp\n"
"parm: NVreg_RegistryDwordsPerDevice:charp\n"
"parm: NVreg_RmMsg:charp\n"
"parm: NVreg_GpuBlacklist:charp\n"
"parm: NVreg_TemporaryFilePath:charp\n"
"parm: NVreg_AssignGpus:charp")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.