#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((1?\d{1,2}|2([0-4]\d|5[0-5]))\.){3}(1?\d{1,2}|2([0-4]\d|5[0-5]))$|^$"
Local $sString = "192.168.1.1" & @CRLF & _
"" & @CRLF & _
"192.168.255.255" & @CRLF & _
"" & @CRLF & _
"8.8.8.8" & @CRLF & _
"" & @CRLF & _
"10.10.1.1" & @CRLF & _
"" & @CRLF & _
"021.8.8.8" & @CRLF & _
"" & @CRLF & _
"8.021.021.8" & @CRLF & _
"" & @CRLF & _
"0.0.0.0" & @CRLF & _
"" & @CRLF & _
"1.0.0.0" & @CRLF & _
"" & @CRLF & _
"100.10.1.1" & @CRLF & _
"" & @CRLF & _
"20.200.2.2" & @CRLF & _
"" & @CRLF & _
"255.255.255.254" & @CRLF & _
"" & @CRLF & _
"266.274.255.0" & @CRLF & _
"" & @CRLF & _
"200.249.255.8" & @CRLF & _
"" & @CRLF & _
"0.0.0.0" & @CRLF & _
"" & @CRLF & _
"1.0.0.0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")