#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<tr(?:(?!<li)[\s\S])*?(ContactUs)[\s\S]*?<\/tr>)"
Local $sString = " <li class="menuItem">" & @CRLF & _
" <a class="menuItem" href="/site/News.aspx?section=316&ViewType=Actual&IdType=316">" & @CRLF & _
" <span class="posNR">2." & @CRLF & _
" </span>News<span class="shortDesc"></span><span class="line"></span></a>" & @CRLF & _
" asdsdasda </li>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <tr class="menuItem">" & @CRLF & _
" <a class="menuItem" href="/site/ContactUs.aspx?section=510">" & @CRLF & _
" <span class="posNR">3." & @CRLF & _
" </span>Contact Us<span class="shortDesc"></span><span class="line"></span></a>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" <tr class="menuItem">" & @CRLF & _
" <a class="menuItem" href="/site/ContactUs.aspx?section=510">" & @CRLF & _
" <span class="posNR">3." & @CRLF & _
" </span>Contact Us<span class="shortDesc"></span><span class="line"></span></a>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" <tr class="menuItem">" & @CRLF & _
" <a class="menuItem" href="/site/ContactUs.aspx?section=510">" & @CRLF & _
" <span class="posNR">3." & @CRLF & _
" </span>Contact Us<span class="shortDesc"></span><span class="line"></span></a>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")