using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<tr(?:(?!<li)[\s\S])*?(ContactUs)[\s\S]*?<\/tr>)";
string input = @" <li class=""menuItem"">
<a class=""menuItem"" href=""/site/News.aspx?section=316&ViewType=Actual&IdType=316"">
<span class=""posNR"">2.
</span>News<span class=""shortDesc""></span><span class=""line""></span></a>
asdsdasda </li>
<tr class=""menuItem"">
<a class=""menuItem"" href=""/site/ContactUs.aspx?section=510"">
<span class=""posNR"">3.
</span>Contact Us<span class=""shortDesc""></span><span class=""line""></span></a>
</tr>
<tr class=""menuItem"">
<a class=""menuItem"" href=""/site/ContactUs.aspx?section=510"">
<span class=""posNR"">3.
</span>Contact Us<span class=""shortDesc""></span><span class=""line""></span></a>
</tr>
<tr class=""menuItem"">
<a class=""menuItem"" href=""/site/ContactUs.aspx?section=510"">
<span class=""posNR"">3.
</span>Contact Us<span class=""shortDesc""></span><span class=""line""></span></a>
</tr>
</ul>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}