# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<tr(?:(?!<li)[\s\S])*?(ContactUs)[\s\S]*?<\/tr>)"
test_str = (" <li class=\"menuItem\">\n"
" <a class=\"menuItem\" href=\"/site/News.aspx?section=316&ViewType=Actual&IdType=316\">\n"
" <span class=\"posNR\">2.\n"
" </span>News<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
" asdsdasda </li>\n\n\n"
" <tr class=\"menuItem\">\n"
" <a class=\"menuItem\" href=\"/site/ContactUs.aspx?section=510\">\n"
" <span class=\"posNR\">3.\n"
" </span>Contact Us<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
" </tr>\n\n"
" <tr class=\"menuItem\">\n"
" <a class=\"menuItem\" href=\"/site/ContactUs.aspx?section=510\">\n"
" <span class=\"posNR\">3.\n"
" </span>Contact Us<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
" </tr>\n\n"
" <tr class=\"menuItem\">\n"
" <a class=\"menuItem\" href=\"/site/ContactUs.aspx?section=510\">\n"
" <span class=\"posNR\">3.\n"
" </span>Contact Us<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
" </tr>\n\n\n"
" </ul>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.