import Foundation
let pattern = #"(<tr(?:(?!<li)[\s\S])*?(ContactUs)[\s\S]*?<\/tr>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<li class="menuItem">
<a class="menuItem" href="/site/News.aspx?section=316&ViewType=Actual&IdType=316">
<span class="posNR">2.
</span>News<span class="shortDesc"></span><span class="line"></span></a>
asdsdasda </li>
<tr class="menuItem">
<a class="menuItem" href="/site/ContactUs.aspx?section=510">
<span class="posNR">3.
</span>Contact Us<span class="shortDesc"></span><span class="line"></span></a>
</tr>
<tr class="menuItem">
<a class="menuItem" href="/site/ContactUs.aspx?section=510">
<span class="posNR">3.
</span>Contact Us<span class="shortDesc"></span><span class="line"></span></a>
</tr>
<tr class="menuItem">
<a class="menuItem" href="/site/ContactUs.aspx?section=510">
<span class="posNR">3.
</span>Contact Us<span class="shortDesc"></span><span class="line"></span></a>
</tr>
</ul>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)