#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(Get-Content\s+(['"]?)C:\\bulk\\).*?(\.txt\2)"
Local $sString = "$line = ''" & @CRLF & _
"Get-Content C:\bulk\XXX.txt | " & @CRLF & _
" Select-String -Pattern 'TEMP' |" & @CRLF & _
" ForEach-Object {" & @CRLF & _
" #blah blah" & @CRLF & _
" }"
Local $sSubst = "${1}BBB$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)