# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Get-Content\s+(['\"]?)C:\\bulk\\).*?(\.txt\2)"
test_str = ("$line = ''\n"
"Get-Content C:\\bulk\\XXX.txt | \n"
" Select-String -Pattern 'TEMP' |\n"
" ForEach-Object {\n"
" #blah blah\n"
" }")
subst = "${1}BBB$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.