re = /(Get-Content\s+(['"]?)C:\\bulk\\).*?(\.txt\2)/m
str = '$line = \'\'
Get-Content C:\\bulk\\XXX.txt |
Select-String -Pattern \'TEMP\' |
ForEach-Object {
#blah blah
}'
subst = '${1}BBB$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result