re = /(?i)(.*Final\s+Exchange\s+Amount.*)/m
str = 'bla bla Final Exchange Amount blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end