using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\s?(a90[\d]+|[$][\d]+|[A-Z]{3}|.*$)";
string input = @"ID: a9000006
NSF Org : DMI
Total Amt. : $225024
Abstract :This SBIR proposal is aimed at (1) the synthesis of new ferroelectric liquid crystals with ultra-high polarization,
chemical stability and low viscosity";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}