$re = '/^\w+\s*(.)\s*\w+\s*\1\s*\w+(?:(?!\1).)*$/m';
$str = 'one,three,four apple is red. match
four, three, one orange is orange. match
one,four,three the sky is blue. match
one,two,four,three not match
four,one,eight,green,three no match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);