using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Process[123]A";
string input = @"Process1A
Process2A
Process3A
Process0A
Process4A
Process1000A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}