# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[A-Z]+\*+|\G(?!^))\K\.(?=[^*]*\*)/*/gm;t' <<< "AG**...**GG*.*
AG**...**GG*.*.G.*C.C"