$re = '/(["\']).*?\1/';
$str = '<span style="font-size:0.58em;font-family:\'Times New Roman\';">
<span style=\'font-size:0.58em;font-family:"Times New Roman";\'>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);