# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[A-Za-z])\s(?=[A-Za-z])//gm;t' <<< "ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -"