import Foundation
let pattern = #"(\.[a-z]*)/administrator"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://m1.aa.example.com/administrator
http://m2.aa.example.com/administrator
http://m5.aa.example.com/administrator
http://m1.bb.example.com/administrator
http://m2.bb.example.com/administrator
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)