import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)/administrator";
final String string = "http://m1.aa.example.com/administrator\n"
+ "http://m2.aa.example.com/administrator\n"
+ "http://m5.aa.example.com/administrator\n"
+ "http://m1.bb.example.com/administrator\n"
+ "http://m2.bb.example.com/administrator";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}