# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)/administrator"
test_str = ("http://m1.aa.example.com/administrator\n"
"http://m2.aa.example.com/administrator\n"
"http://m5.aa.example.com/administrator\n"
"http://m1.bb.example.com/administrator\n"
"http://m2.bb.example.com/administrator")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.