using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bIMIS\/C\/\d+\/\d+\/\d+\/\d+\/\d+\b";
string input = @"Being Settlement of school fee, student Number IMIS/C/28727/14/7/2022/28980 in respect of Tony Alex";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}