using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/\/\s*COLORS)[\r\n]+(.*)(?=\/\/\s*END\s*COLORS)";
string input = @"// COLORS
$nipiter-green : #158C3F;
$green : #048e3c;
$light-green : #C4E2CF;
$nipiter-red : #e11b1c;
$dark-red : #a11b1b;
$black : #000000;
$dark-gray : #4c4c4c;
$gray : #e4e4e4;
$white : #ffffff;
$transparent-white : rgba(255, 255, 255, 0.59);
$feminist-purple : #2a1736;
$yellow : #ffff73;
$twitter-blue : #5a8dbd;
$facebook-blue : #184f83;
// END COLORS";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}