using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<date>\S+)\s(?<time>\S+)\sp=(?<id>[\d]+)\su=(?<user>[\w]+)\s\|\s*TASK\s*\[(?<task>[^\]=]*)\s\w+=";
string input = @"2019-03-24 17:57:14,202 p=19455 u=root | TASK [this is the task name msg=Debug message] ************************";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}