import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<major>0|[1-9]\\d*)\\.(?<minor>0|[1-9]\\d*)\\.(?<patch>0|[1-9]\\d*)(?:-(?<preRelease>(?:[a-zA-Z1-9][a-zA-Z\\d]*|0\\d*[a-zA-Z][a-zA-Z\\d]*|0)(?:\\.(?:[a-zA-Z1-9][a-zA-Z\\d]*|0\\d*[a-zA-Z][a-zA-Z\\d]*|0))*))?(?:\\+(?<metadata>(?:[a-zA-Z\\d-]*)(?:\\.(?:[a-zA-Z\\d-]*))*))?$";
final String string = "0.1.0\n"
+ "01.2.1\n"
+ "1.2.0\n"
+ "1.0.0\n"
+ "1.01.0\n"
+ "1.0.01\n"
+ "1.0.0-0df34.ahgdfhsdf.0005a56tg\n"
+ "1.0.0-0054.df4gf\n"
+ "1.0.0-005a4.df4gf\n"
+ "1.0.0-005a4.df4gf+adffbff.sdfg.sdfg.adf78df7d8df7\n"
+ "1.0.0-005a4.df4gf+adffbff.sdfg.sdfg.00000000.dfsg.sdf-sfg.sdfg-sdfg.sgf\n"
+ "900.10.85494\n"
+ "0900.10.54";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}