$re = '/^N_([A-Za-z]+)-([A-Za-z]+)-([A-Za-z0-9]*)-([A-Za-z0-9_-éÉ\s]+)---/m';
$str = 'N_aa-AAAA-140143-AAAAAA_1---
N_AA-AA--AAAA_1---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);