re = /^N_([A-Za-z]+)-([A-Za-z]+)-([A-Za-z0-9]*)-([A-Za-z0-9_-éÉ\s]+)---/m
str = 'N_aa-AAAA-140143-AAAAAA_1---
N_AA-AA--AAAA_1---'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end