$re = '/^(?:[+-]\d+|(?:[01][0-9]|2[0-3]):[0-5][0-9])$/m';
$str = '+120
-15
17:56
18:89
-
+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);